Tutorials: Compiling Wallet on Ubuntu

From RPICoin Wiki
Revision as of 02:27, 8 September 2018 by Musky (talk | contribs) (Installation wallet on Ubuntu)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Installation wallet on Ubuntu

Requirements

  • OS Version 4.1+ (Might also work with older versions - note: be carefull as this has not been tested)
  • Storage: Free stroge of at least 4GB (1 or 2GB will do but may cause the application to hang).
  • For best staking results make sure to have your android wallet online for 24/7 with a stable Internet Connection

Installation

  1. Open the terminal or login with SSH
  2. sudo apt-get update && sudo apt-get upgrade
  3. sudo apt-get install qt5-default qt5-qmake qtbase5-dev-tools qttools5-dev-tools build-essential libssl-dev libdb++-dev libboost-all-dev libqrencode-dev libminiupnpc-dev
  4. sudo apt-get install vim git
  5. git clone https://github.com/rpicoin/rpicore.git
  6. OR download the precompiled walllet from Official Github
  7. cd /rpicore/src/
  8. make -f makefile.unix clean
  9. make -j 4 -f makefile.unix this can take some time!
  10. ./rpicoind -daemon (To start the Daemon)
Ínstall the GUI
  1. cd ..
  2. qmake
  3. ./rpicoin-qt (To start the GUI)

Cannot allocate memory error during make

  • make: virtual memory exhausted: Cannot allocate memory
  • Use less jobs during compiling (make -j 2 -f makefile.unix) or increase / enable your swap file
  1. sudo fallocate -l 1G /swapfile
  2. sudo chmod 600 /swapfile
  3. sudo mkswap /swapfile
  4. sudo swapon /swapfile
  5. echo '/swapfile none swap sw 0 0' | sudo tee -a /etc/fstab
  6. reboot system